Router TP-Link TL-WR1043ND con OpenWRT para Movistar FTTH

Como ya comenté en un artículo anterior sobre la configuración de DD-WRT para funcionar con la FTTH de Movistar, el router que suelen subencionarte es bastante mediocre en sus funciones. En esta entrada voy a explicar cómo configurar un router alternativo (en este caso el TP-Link TL-WR1043ND) que tiene un precio bastante asequible y permite la instalación de OpenWRT.

tp link tl-wr1043nd FrontalEl router tiene Wifi-N, USB y ethernet a Gigabit como caracteristicas más destacables. Además, incluye un procesador Atheros AR9132 con 32 Mb de RAM.

En la parte trasera podemos ver diferenciadas las entradas de “Internet” (en azul) y el switch hacia la red interna (en amarillo). A pesar de estar diferenciadas, internamente se trata de la misma interfaz de red, sólo que mediante software se diferencian cada una de las bocas.

La versión de OpenWRT que vamos a usar es la 10.03.1 (Backfire), podemos descargar el archivo imagen de su repositorio. Nos interesa el archivo

<a href="http://downloads.openwrt.org/backfire/10.03.1/ar71xx/openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin">openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin</a>

He redactado un nuevo post con un firmware personalizado para funcionar con Movistar FTTH y este router. Este firmware basado en la última versión de OpenWRT (12.09) ahorra todo el proceso de configuración descrito más abajo.

Nota importante: Carlos, un lector, ha comentado que hay problemas con ciertas versiones de este router y openwrt. Estas versiones de router pueden morir si el firwmare no es el correcto o es incompatible. Más información la podéis obtener aquí:

<a href="http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd" rel="nofollow">http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd</a>

Es muy importante que sea el factory para poder cargar esta imagen desde el firmware original del router.

TL-WR1043ND Trasera

Dentro de la configuración original del router nos vamos a a la sección System Tools y de ahí a Firmware update.

En esa sección escogemos el archivo que nos descargamos antes y pulsamos en el botón Upgrade.

Interfaz OpenWRT

Unos minutos después el router se reiniciará y ya tendremos OpenWRT instalado. Ahora sólo queda configurarlo.

Empezaremos configurando la boca azul de internet para que marque los paquetes para usar la vlan6 utilizada por la ONT que provee Movistar.

Nos vamos a la sección Network -> Switch y establecemos las opciones tal y como se ven en la imagen:

Configuracion vlan
El puerto 1 corresonde con el puerto azul de internet. Hemos añadido una nueva entrada pulsando sobre Add, marcado el puerto como tagged y asignado el Vlan ID 6.

El resto de puertos permaneceran sin marcar, ya que no voy a hacer uso de VLANs en mi red.

Ahora debemos asociar la interfaz virtual WAN con la nueva VLAN creada. Para ello nos vamos a la sección Network -> Interfaces -> WAN y en la pestaña Physical Settings marcamos la VLAN eth0.6. Si no aparece, deberemos pulsar en Save & Apply antes.

Configuracion Vlan
Ahora configuraremos el demonio PPP para hacer uso de la conexión. En la pestaña General Setup de la misma sección establecemos el protocolo a PPPoE, usuario adslppp@telefonicanetpa contraseña adslppp.
Configuracion PPPoE
Guardamos y aplicamos los cambios en el botón Save & Apply. Y ya deberíamos tener la conexión activa, que podemos ver en la pestaña Status.
Configuracion ppp movistar

 

Esta entrada fue publicada en General, Linux, redes, Tecnología y etiquetada , , , , . Guarda el enlace permanente.

56 respuestas a Router TP-Link TL-WR1043ND con OpenWRT para Movistar FTTH

  1. Ricardo dijo:

    Excelente aportación.He comprado este router y soy incapaz de instalarlo con su software y la ont huawei de telefónica.¿La única manera es la que tu describes? Y si es así; se puede con éste firmware desactivar ep SIP ALG, necesito hacerlo para usar la VOip.
    ¿Se puede volver al firmware original del fabricante? por si tengo problemas después.
    Gracias

  2. La verdad es que no me paré mucho con su firmware original. Compré el router porque sabía que era compatible al 100% con OpenWRT y quería usar este sistema operativo. Siempre que he leído algo de SIP ALG viene acompañado de críticas muy duras porque muchos fabricantes lo implementan muy mal en sus routers. Podrías intentar actualizar el firmware original a la última versión http://www.tplink.com/en/support/download/?model=TL-WR1043ND

    Por otra parte OpenWRT es una pequeña distribución de linux, y su instalación por defecto tiene un mínimo de funcionalidades. Por defecto no tiene nada para el tratamiento de enrutado de VozIP. Así que no deberías tener problemas.

    Tambien es posible devolverlo a su estado original a través del menú Sistema->Backup/Restore . Aunque este paso debe hacerse con mucho cuidado y seleccionando correctamente la imagen de carga. Tienes más información en este enlace: http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#back.to.original.firmware

  3. Ricardo dijo:

    Muchas gracias por tu respuesta, al final seguí tu paso a paso y fue muy sencillo.Conseguí instalarlo con la ONT de Telefónica y eso que en el servicio técnico me dijeron que ers imposible quitar el router de ellos que no funcionaria la conexión.
    Lo bueno; que funciona toda la red con los 6 equipos que tengo y la VozIp sin problemas, muy a pesar de telefónica.
    Lo malo; que sin el sotfware original del router no se puede hacer uso del puerto usb para conectarle un hdd….

  4. Me alegro Ricardo. 😉

    Sobre lo de usar el USB, ten en cuenta que tienes una distribución de linux completamente funcional en el router. El software que trae de base cubre las necesidades principales, pero puedes instalar muchas más cosas. Es más, puedes hacer uso del puerto USB para muchas más funciones que con el firmware de serie. Puedes usarlo para compartir impresoras, hdds, camaras de vigilancia, módem 3G, … casi todos los cacharros usb están soportados.

    http://wiki.openwrt.org/doc/howto/usb.storage
    http://wiki.openwrt.org/doc/recipes/3gdongle

    Si buscas por los términos “openwrt usb luci” tendrás muchos enlaces donde explican estos pasos.

  5. Pere dijo:

    Buenas Alfredo,

    Muchas gracias por la aportación, funciona de maravilla. Llevo un par de días discutiéndome con este router y la fibra óptica, y después de pasar por dd-wrt, openWrt y volver al firmware original, ya me había dejado por inútil jejeje.

    Ahora a mirar de configurar el USB para que me haga de servidor de impresión, a ver que tal me sale

    De nuevo muchas gracias! Un saludo!

  6. ea4eng dijo:

    Yo estoy muy desconcertado con la ftth. No se si se puede hacer lo que necesito con el firm de openwrt. Tengo un servidor detrás del router y no funciona desde la red donde se encuentra el mismo. Cuando pongo la dirección publica o intento entrar en la página web el router me ofrece el gestor para que lo configure. Pero desde fuera de mi ubicación funciona bien. Osea que estoy a medias. Mi pregunta es si esto que quiero hacer, se puede hacer con openwrt. El otro día compré el router tp-link del que habláis, le puse el firm y cuando empecé a tocar los puertos en switch se quedó colgado y se briqueó. Como lo acababa de comprar por la mañana, lo descambié por otro y ahora lo tengo virgen otra vez. (con el firm original de fabrica). Necesito un poco de ayuda.
    Gracias por adelantado.

  7. Jose dijo:

    Hola Alfredo!

    He puesto en casa recientemente ftth 100mb de movistar. Con la conexión estoy contento, ya que funciona (cuando me deja el router) bastante bien. Estoy leyendo por todos sitios y lo que busco es una solución económica (lo más que se pueda) y que funcione bien, ya que el comtred que te da movistar es una auténtica basura, no consigo abrir puertos y el wifi se queda muerto muy amenudo, tendiendo que resetearlo continuamente.
    Una pregunta, el ont de alcatel también es compatible con este router?
    También tengo un NAS QNAP, el cual lo utilizo tanto como servidor FTP y para descargas torrent, y me gustaría poder acceder desde cualquier ordenador fuera de dicha red. ¿Todo esto se podría hacer?

    Muchas gracias por anticipado, y comentarte de que gracias a esta página y al tutorial que has puesto seguramente me decante por este equipo si me confirmas de que todo esto se podría hacer.

    Un saludo y gracias de nuevo.

  8. Jose dijo:

    Otra pregunta, este router lo tienes conectado directamente al ont o lo tienes conectado al router comtrend??
    Yo tengo instalado los 100mb de ftth, será capaz de darme los 100 mb o alomejor se queda un poco justo??

    Un saludo y gracias.

  9. Jose dijo:

    Y otra cuestión que se me olvidaba, se puede utilizar vo-ip con este router??

  10. Jose dijo:

    Gracias por borrar mis comentarios, muy amable por tu parte.

  11. Jose dijo:

    Disculpa, al entrar no he visto los comentarios y pensaba que los habías borrado. Mil disculpas por el anterior comentario.

  12. Buenas a todos, intentaré responder a vuestras consultas:

    ea4eng. No entiendo muy bien lo que estás intentando hacer. Si te refieres a dar visibilidad desde Internet a tu servidor dentro de tu red privada. Debes configurar la sección NAT del router. En la sección de firewall de OpenWRT tienes un apartado “Redirections”, donde le indicas el puerto externo (en tu caso será el 80 o 443 por ser para web) y redirigido a la IP interna de tu servidor con los mismos puertos. De esta forma cuando alguien de fuera haga una petición al 80 o 443 se “redirigirá” hacia tu servidor web interno.

    Jose, las ONTs son compatibles con este router, ya que utiliza VLANs para comunicarse y este medio es estándar en casi toda la electrónica de red.
    Para acceder a tu QNAP utiliza la misma sección que le he indicado a ea4eng. En “redirections” podéis decir qué puerto externo se redirige a qué IP y puerto interno.

    No soy comercial de TP-LINK ni de OpenWRT, pero estoy pensándome hacerme partner o algo 😀

    Mi router lo tengo directo a la ONT, por su interfaz WAN y con la configuración del artículo.

    Los comentarios de este blog los tengo moderados, es necesario debido a la gran cantidad de SPAM que llega. En cuanto puedo, desbloqueo los comentarios.

    Saludos.

  13. Jose dijo:

    Y el tema de la vo-ip, se podrá configurar con este router?

    Es que he leido en algún foro que da problemas y no se si se podrá o no.

    Un saludo y gracias por adelantado.

  14. ATLAS dijo:

    Gracias Alfredo por la información. Pero con los routers WR1043 v1.9 y el OpenWRT backfire no funciona el puerto WAN.

  15. xx dijo:

    puede ser q la configuracion en un linsys54gl no funcione?

  16. Carlos dijo:

    Gracias Alfredo por este detallado tutorial. En principio está todo muy claro pero lo sigo al pie de la letra y no se conecta la WAN. ¿Qué puedo revisar? los pantallazos los tengo igual y nada de nada. He tenido que volver a poner el Comtrend! Gracias de antemano. Otra cosa, en tus pantallazos aparece la pestaña “services” que yo no la tengo.

  17. ATLAS, por lo que he podido averiguar es un problema del firmware incluido en ciertas versiones del router wr1043ND. El firmware apaga el puerto WAN al hacer una actualización de firmware, con lo que se queda desactivado para siempre. Hay una “ñapa” o workaround que parece funcionar:

    http://www.dd-wrt.com/phpBB2/viewtopic.php?p=712604#712604

    Básicamente, se trata de cargar un firmware original modificado en el router para que no apague el puerto wan al cambiar de firmware. Una vez hecho esto cargar el firmware que más te guste dd-wrt u OpenWRT.

    En el enlace que te he pasado tienes las utilidades y el firmware necesario para hacer el proceso.

    No he podido probarlo porque mi router no se ve afectado por este fallo. Espero haberte ayudado.

  18. Carlos, creo que te ocurre lo mismo que a ATLAS. Mira el comentario de respuesta anterior.

  19. XX, esta configuración está probada en el router tp-link wr1043nd, aunque no creo que haya que modificar mucho para hacerla funcionar en un linksys 54GL. El linksys ha sido durante muchos años el dispositivo preferido de desarrollo para este tipo de firmware y todo debe estar más que probado. Siento no poder ayudarte al no tener disponible un router como ese para probar.

  20. marco emilio parada lizcano dijo:

    hola, queriendo mejorar la calidad del router me dispuse a actualizarlo a openwrt, ley varias explicaciones descargue el software del sitio que el tuto me indicaba, lo conecte por cable y ejecuta la instalacio cargo la barra y me dio un aviso de upgrade satisfactory o algo asi y se reinicio ,,, pero no apararecio mas salio el aviso sitio no encontrado (192.168.0.1) LO INTENTE VARIAS VECES Y CON OTROS PARECIDOS (,,,,,, O.1,,,0.1, 0.2 ETC) Y ABSOLUTAMENTE NO APARECE tambien resetee y nada. le agradezco que me pudiera colaborar teniendo en cuenta que se muy poco de computadores. gracias

  21. x7iBiT dijo:

    ea4eng : lo que necesitas activar es una opción que se llama NAT Loopback (puede que se llame NAT Reflection en el OpenWRT). Por supuesto el puerto correspondiente tiene que estar abierto para la IP local del equipo en donde está montado el servidor. Sin embargo, aunque el puerto esté abierto, si intentamos acceder al servidor a través de la IP de Internet (o desde un dominio redireccionado al estilo no-ip.com o DynDNS) desde dentro de la red local no podremos. Por el contrario si intentamos acceder desde fuera de nuestra red, el servidor responderá sin problemas, pero desde nuestra red no lo hará a no ser que activemos dicha opción.

  22. Miguel dijo:

    Hola Alfredo!

    Antes de nada, darte las gracias porque he odido configurar el router perfectamente siguiendo tus instrucciones.

    Sólo me queda configurar la VoIp. He visto por “San Google” que tengo que habilitar la VLAN3 pero no tengo ni idea de lo que hacer. Podrías ayudarme? o darme alguna indicación de dónde encontrar más información?

    Muchas gracias.

  23. Ricardo dijo:

    Muy buenas Afredo; estoy encantado con el router y el OpenWRT, pero tengo que bloquear el P2P y no sé como hacerlo, mi inglés es un poco insuficiente y mis conocimientos de aplicar reglas de firewall también. Tengo constancia que se usa el emule sin mi consentimiento y quiero impedirlo.
    Muchas gracias por todo

  24. Ricardo dijo:

    Corrijo: ALFREDO.

  25. Carlos dijo:

    Me decidí a seguir el manual sin comprobar en la web de OpenWrt la tabla de compatibilidades y he acabado con mi maravilloso Router nuevo Inoperativo/Brickeado, los que tengáis la versión 1.2 Alemana absteneros de usar la 10.03.1 Backfire o acabáreis como yo.

    Más info aquí: http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd

  26. Martin dijo:

    ¿Es posible configurarlo para usar imagenio sobre FO-100mb? Desde tiempos del Zyxel ha sido muy complicado por la telecarga ftp y aunque funciona la guia no carga.

  27. Alan dijo:

    Alfredo, en primer lugar gracias por el tutorial. Escribo porque seguí los pasos que detallas pero no tengo conexión. El modem que me instaló Movistar es el I-240G-B y el router es el 1.8, pero antes de instalar OpenWRT seguí los pasos de downgrade que aparecían detallados en la página para evitar que el puerto deje de funcionar. Al conectar el cable la luz de WAN se enciende y el modem también enciende la luz de LAN1 así que supongo que el downgrade lo hice bien. No hay caso de que me de internet, ayuda por favor!

  28. antonio dijo:

    yo tengo un link 750 i no tengo huevo aserlo funcionar con la fibra de moviestar

  29. Diego dijo:

    Hola Alfredo, tengo unas dudillas.Tengo fibra movistar 100mb , la ont y un router comtrend.Mi duda es, puedo sustituir el router comtrend por este que dices tu directamente desde la ont?.Es decir quitar el comtrend de la ont y poner el TP-LINK WR1043ND directamente a la ont.Tendre internet sin probleas?.Tambien me funcionaria el wifi?.Con este tutorial es suficiente para que el router funcione con wifi y a pleno rendimiento?..Muchas gracias

  30. Jordi Saez dijo:

    Hola Alfredo,

    Acabo de adquirir el TP-link TL-WDR4300 para instalarle OpenWRT y usarlo con mi fibra de Movistar. Tengo varias dudas a ver si me puedes echar una mano. Aunque sea fibra, el protocolo utilizado es PPPoE como si fuera una ADSL? Hay mucha direferencia a la hora de configurar un modelo o otro? Entiendo que será Vlan 6 en el puerto que conecta con la ONT siempre, no? Lo que he encontrado es que el entorno web (Luci) no viene instalado depende de que firmware y que me pide que el equipo también esté conectado a Internet para actualizar paquetes. Me puedes guiar un poco?

    Perdona las molestias y gracias de antemano.

    Saludos,
    Jordi

  31. Ignacio dijo:

    Gracias Alfredo, acabo de configurar (mayo 2013), siguiendo tus instrucciones, un Router TpLink tl-wr841nd de menos de 30 € y funciona de maravilla con la ONT de Movistar. La fase de configuración de WAN es un poco distinta porque hay que crear (custom) la eth0.6 “Physical Interface” pero todo perfecto. Tengo además un repetidor Tplink TL-WA850RE y la red llega ahora a toda la casa rápida y estable.

  32. yeray dijo:

    hola alfredo como a otros usuarios e descargado el OpenWRT y lo instale y ahora el puerto wan no me funciona como puedo areglarlo?

  33. yeray dijo:

    alguien puede contestar como areglar lo de puerto wan

  34. Pat dijo:

    Hola Alfredo y demás expertos,

    tengo el mismo problema que Marco Emilio… he hecho el upgrade y al refrescar la pagina el solo ya no podia recargar. He verificado el gateway ip y en un primer momento salia vacio!!! D:
    He intentado de todo y buscando como un loco por Google, pero nada de nada, ahora me dice gateway ip 0.0.0.0… y si conecto el router por WAN se queda como si no le conectas nada :/
    Ayuda porfa!!! Estoy desesperado! 🙁

  35. Krishach dijo:

    Gracias Alfredo, recibí ayer mismo mi router y ya lo tengo configurado, y la verdad es que va como un tiro. El único punto a tener en cuenta es que lo compré en Amazon, y me lo mandaron desde alemania con la revisión 1.2(DE), que NO ES COMPATIBLE con el firmware que enlazas en el artículo, y que como algunos compañeros han dicho puede brickear el router. La solución es tan sencilla como instalar la última versión del OpenWRT, que ya soporta el nuevo bootloader de las nuevas revisiones del router, y además resuelve el problema de que no funcione el puerto WAN. Os adjunto el enlace a la imagen que utilicé yo sin problemas: http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin

    @yeray: Esta versión de firmware debería resolver el tema de que no te funcione el puerto WAN. Al parecer es un problema de Backfire con los bootloaders incluidos en las ultimas revisiones de firmware de este router. Este problema no existe con la ultima versión de OpenWRT (Attitude Adjustment).

  36. juan dijo:

    Hola
    Gracias por ayudarnos a los que estamos probando. Tengo el ADSL de fibra y como a todos, va fatal el router de telefónica.
    He seguido vuestros pasos y comentarios, comprado este router pero algo debo haber hecho mal porque tras cargar le la imagen el router, ya no puedo acceder a él.
    ¿Sabéis como o que debo hacer para volver a tener control del equipo?
    He buscado por internet pero mi ingles es bastante bajo (nulo) como para no enterarme de nada cuando leo foros en ingles.

    Gracias

  37. Javier dijo:

    En primer lugar agradecer el tutorial, muy ilustrativo y bien explicado.

    Luego, comentar que he instalado la última versión de OpenWRT (Attitude adjustment) en el router sin ningún contratiempo. En teoría se puede hacer directamente y el comentario de “Krishach” lo confirma, yo para curarme en salud (se tarda 2 minutos) hice el downgrade al firmware original alemán que indica en la página antes de instalar el OpenWRT. Todo fue como la seda.

    Por supuesto, la diferencia con el router de Movistar es bestial. Yo ya tenía este router con su firmware original desde hace año y pico para el ADSL, y cuando uno se acostumbra a lo bueno es complicado volver atrás. Es cierto que el router Comtrend para fibra óptica es un poco mejor que la basura que dan para el ADSL, pero aún así este es muchísimo mejor, solo por la diferencia en el alcance de la Wi-Fi ya vale la pena, pero hay muchos motivos más.

    Lo dicho, animaros porque este router es una pequeña joya, y no dudéis en instalarle Attitude Adjustment, es una pasada como va.

  38. gorby dijo:

    Wenas noches ,llevo con este router 12 días sin ningún corte , me costo mucho ponerlo en marcha porque tenia la ver. 1.10 entonces no funccionava el wan con openwrt.
    A final con varios intentos y cambios de firmware lo bloque ( el famoso brick) . Ha tenido q comprarme un usb-ttl el llamado andruin.
    Si alguien llega a este paso los cables tx y rx debes ponerlo cruzados.LE dejo unas informaciones q vienen en ingles.
    https://forum.openwrt.org/viewtopic.php?id=38424
    estos pasos lo ha siguido yo y a través de mas de 8 horas me funcciono
    este es el andruin :
    http://www.conectrolinformatica.com/arduino-shield/2681-placa-arduino-uno-rev-3.html
    ALFREDO una pregunta : el wifi debe funcionar bien bien? a mi me parece q es un poco flojo ,es menos velocidad
    SI puedes poner unas fotos con las config de router ,mas completas ,dns etc
    UN saludo y gracias, tengo 100 megas ffth movistar ,el ont no se q marca es y el router comtrend esta en cajón!!!!

  39. knob2001 dijo:

    Hola!…

    Parece que el foro de alfredomatas (hola, alfredo, encantado) es el último reducto para los que tenemos un 1043ND. Como sabéis, ahora por la fibra ponen Movistar TV gratuito (6 canales, creo).

    ¿Algún tipo de tutorial para los que ya tenemos el ONT+1043ND funcionando?

    Un saludo.

  40. DIEGO G. dijo:

    Hola Alfredo!, ya se que el tema es de hace tiempo y no sé si me responderás. El problema mío es el siguiente. He intentado hacer los pasos como indicas y cuando he actualizado el firware ya no he podido acceder a l a configuración del router. Que es lo que me ha podido pasar?¿. Puede que haya muerto el router a no ser compatible con la versión que tuviera, como pones que un lector (Carlos) comenta. Yo la verdad es que lo he intentado actualizar sin mirar antes, ya que la página estaba en inglés y no entendia bién como mirarlo. Ayuda por favor. Gracias. Un saludo.

  41. juan dijo:

    Despues de seguir este foro durante un tiempo, compre el router tlwr1043nd como me hice un lio con la actualización me lo han cambiado por el airlive N4550R, y sin firmware de actualización ya tengo mi router funcionando sin problemas.

  42. Francisco Jimenez Exposito dijo:

    Estoy a punto de dar el paso, pero me asalta la siguiente duda.

    Actualmente tengo instalados 2 decos de Imagenio conectados por Ethernet y supongo
    que si hago el cambio seguirian funcionando ?

    Gracias

  43. karlitrosvk dijo:

    Yo también me instalé un Airlive N4550R y me va de lujo con la fibra de Movistar. En el servicio técnico te explican cómo configurarlo y como he dicho, me va de cine.

  44. Magnus Agard dijo:

    Hola,
    Empecé instalando el firmware alemán (wr1043nv1_de_3_9_17_up_boot (100.331). Bin) y el router funcionaba bien, pero después de instalar DD-WRT a partir de (OpenWRT-ar71xx-generic-tl-WR1043ND-v1-squashfs-factory.bin) el router acaba de morir, no puedo ponerlo en el modo a prueba de fallos (failsafe mode), no hay parpadeo rápido del LED después de pulsar QSS, los LEDs sólo parpadean dos veces y luego no pasa nada más. He intentado telnet y ethernet, a través de eth0 con IP 192.168.1.1, pero no hay respuesta.
    Alguien tiene ideas o soluciones?

  45. Pingback: OpenWRT para Movistar FTTH | Alfredo Matas

  46. Jordi dijo:

    He comprado un TL-WR1043ND esta semana y viene de la versión 2, por lo que el firmware enlazado en el artículo no sirve (es para la 1).
    Al instalar el OpenWRT que he encontrado para él (Barrier Breaker r39211) descubro que no lleva Luci. Se lo instalo desde ssh (para tener internet primero contecto un cable de red del Comtrend de Movistar al puerto WAN edl WR1043ND), y ya puedo probar los cambios sugeridos eneste artículo.
    Hay alguna diferencia con el artículo en la pestaña de Switch: el orden es distinto, hay un puerto más, el puerto de WAN no es el 1 sinó el 5 (se ve al desconectarlo y ver como cambia el estado)
    He puesto la configuración que viene por defecto en http://screenpresso.com/=nPTaf
    Pero el problema es: cuando cambias el estado de la primera columna (CPU) el router deja de responder a la LAN, y tienes que resetear y volver a empezar (ssh, Luci, …).
    Por ello, me ha sido imposible configurarlo para Movistar FTTH con estas instrucciones. La WAN nunca llega a sincronizar.
    Otra diferencia es que hay un interface más, llamado WAN6, con la MAC a 0:0:0:0. He probado de borrarlo, de tener los dos, y nada.

    Alguna idea?

  47. José Antonio dijo:

    Lo primero de todo… muchas gracias.
    Tu trabajo es excelente.
    He instalado en mi TP-Link WR1043 v1.1 y ha funcinado a la primera, pero cuando uso el torrent, se suele quedar “tostado” y tengo que reiniciarlo. Uso windows 7 64 bits y me conecto a traves de un “pincho” wifi D-Link DWA140. Desconozco si se pueden instalar parches o si se puede hacer algún test, configuración, etc… para solucionar el problema. Buscando por foros veo que no soy el único que tiene problemas con este modelo.
    ¿Alguna sugerencia?
    Muchas gracias.

  48. David dijo:

    Hola compañero, espectacular trabajo antes de nada!!!!. A ver, te comento lo que me ha pasado….

    Resulta que ayer me llegó este router, y le metí un OPENWRT pero sin darme cuenta le metí uno que venía sin luci, cuando pensaba que me lo había cargado por no cargar el servidor web, resulta que había que instalarlos conectándo el router a internet y descargando los paquetes. Bien esta tarde al llegar del curro, lo primero que he hecho, “updatearlo” e instalarlo, con esto me ha aparecido el servidor web perfectamente.

    Entonces he ido a configurar parámetros wan y lan, pero no se que he hecho / dejado de hacer….que al reiniciar para aplicar la configuración, ya no me deja entrar por servidor web de nuevo. Pero lo peor, es que intento re”updatearlo”….pero me sale con que no tiene conexión a internet!!!! estoy pensando que quizás pueda ser que haya desconfigurado algo antes, pero no creo. La cuestión es a ver como puedo desde telnet acceder, para cargar de nuevo los paquetes luci por usb (si es posible). porque ahora mismo, está literalmente muerto 🙁

    Gracias de antemano

  49. Pingback: TG789vn Movistar y Torrent

  50. Pingback: Anónimo

  51. Antonio dijo:

    Hola muy buenas Alfredo y Jordi me podríais ayudar a poner el openwrt y configurarlo para fibra moviestar, vozip, internet. Soy un poco novato pero leyendo y viendo tutoriales aprendo , he visto varios tutoriales pero me he pierdo porque leo pero no llego a entender a lo que se refieren

  52. Sergio dijo:

    Buenas tardes Alfredo,

    Recientemente he comprado un TL-WR1043ND. Lo estoy intentando substituid por el router comptrend de movistar fibra. Lo conecto a la ont y lo conecto a mi mac. Tras entrar en la interface y darle al auto-detect me dice que no ha podido detectar mi tipo de red. Abro manualmente y entro los datos de la red pppoe de movistar. A partir de allí, hago el reboot y no hay manera que se conecte! Me podrías ayudar? Me estoy dejando lo? O alguna idea de porqué no funciona lo del autodetect? En otros foros dicen que la instalación es super fácil y para mi está siendo una pesadilla:(
    Te agradeceria muchísimo tu ayuda.
    Un saludo!

  53. Pingback: Anónimo

  54. Pingback: Gargolyte Vlan

  55. Rafa R dijo:

    La verdad es que fue una suerte encontrar tu blog, gracias por contestar tan rápido por twiter y solucionar nuestro problema, un servicio de 10, un saludo!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *